Back to overview
Degraded connections
Mar 17, 2026 at 10:13pm UTC
Affected services
api.windbornesystems.com/health
Resolved
Mar 17, 2026 at 10:13pm UTC
All systems back to normal operations
Affected services
Resolved
Mar 17, 2026 at 10:13pm UTC
All systems back to normal operations
Affected services